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Overview

e-Cruise Control is designed to facilitate testing real-time and embedded systems. The
application consists of two primary components: the Master Control Console (MCC) and
the Driver Console (DC). The MCC incorporates a series of slide bars and controls to
enable various settings to be broadcast to the DCs.

The application is used in a testing environment as a vehicle to demonstrate various
techniques for testing and identifying testable conditions.

The MCC is operational and the objective of this document is to specify the required
functionality of a DC.

Quality Assurance / Tester Introduction

This is a multifaceted exercise to automate the testing of a real-time embedded
application. Quality Assurance participants will perform the following tasks:

1. Confirm their understanding of the requirements by diagramming the problem. It
may be necessary to use more than one type of diagram. (A State Machine may
be your best choice.)

2. Develop a system test plan for the application.

3. Review the system test plan and make adjustments as necessary.

4, Use the DC template to program the application.

5. Review the code you inserted into the template.

6. Test the application using the system test plan and report the results. A basic
report that uses the audit trail is sufficient. The report should be available via an

on-line web page. (The link must be sent to the instructor.)

A functional overview table follows. It outlines the basic requirements of the system.
Additional details will be found in the specification portion of the document.

Functional Overview

The e-Cruise Control Master Control Console will communicate with the Driver Console
modules by transmitting signals that identify the current settings of the following console
elements:
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Master Console

Driver Console

Ambient Light

When the light level goes below a
predetermined threshold, the lights must go on
automatically and the indicator is set ON
specifying that the lights are needed.

Tire Pressure 1 Driver Front (DF)

Tire pressure should be at 32 PSI. If the
pressure is over or under the recommended
pressure an indicator
AHIi gho and the tire pi
deviation from normal. When it is at 32 PSI, the
indi cator wi || di spl ay

Note that each tire must be monitored.

Tire Pressure i Passenger Front (PF)

See tire note for DF.

Tire Pressure i Driver Rear (DR)

See tire note for DF.

Tire Pressure i Passenger Rear (PR)

See tire note for DF.

Engine Temperature

When the temperature goes above a predefined
value. An indicator must go on to indicate that
the engine is overheated. See table.

Rain

When rain is communicated, the wipers must go
on automatically. Wipers operate in four modes:
off, low, medium, or high depending upon the
amount of rain.

Speed

The speed is used to determine if a warning
indicator goes on when a predetermined speed
is exceeded.

Time

For testing purposes, time may be accelerated
by a factor of 2x up to 400x. The console must
have a digital clock that indicates time as it is
transmitted by the Master Console.

Miles per Gallon (MPG) is computed and
displayed.
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Specification / Required Functionality

The DC will be required to do the following:

1.

Read signals being broadcast by the MCC. The signal will indicate:

A.

Vehicle speed (-10 to 160 MPH) If the speed is 0, the vehicle is not
moving. A negative speed indicates the vehicle is in reverse.

Ambient light (dawn begins, dusk begins) In low light conditions the
automobile lights should be on. In some states there is a requirement that
when the windshield wipers are on, the headlights must be on as well.

Weather condition (drizzle to torrent) When there is precipitation the
windshield wipers must be used.

Tire pressure for each tire (DF-driver front, PF-passenger front, DR-
Driver Rear, PR-passenger rear. These gauges will alert the driver to a
conditions where the tires are over inflated, underinflated, or inflated
properly at 32 PSI.

Engine temperature If the engine gets to warm there must be an
indicator to alert the driver to an overheating situation.

Adjustable clock. The DC will determine the time multiplier and the clock
can run at actual time or from 2X to 400X (from 2 to 400 times actual) The
clock is also used to measure elapsed time.

Compute MPG based upon the speed of the vehicle and fuel
consumption. Each vehicle will get 30 MPG at speeds below 55 MPH,
and 25 MPG at a speed of 55 MPH or greater. (Reminder: a negative
speed indicates that the vehicle is in reverse, but they are not rewarded
with extra fuel while backing up.) The DC will refuel automatically.

The above table identifies the indicators and the basic functionality of the
application. Additional requirements are outlined below.

The DC will have a user interface that reflects the dials and gauges on an
automobile dashboard. The designed interface may be generic, and does not
have to be modeled after a specific make or model of an automobile.

A.

The console will have the ability to set a speed control warning. This may
be an audible indicator, a message or a light. The light would simply be a
circular shape that is green when the vehicle is operating below the speed
alert setting. It becomes red when the alert speed is exceeded. It returns
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to green when the speed goes below the speed alert setting. Switch
settings would work in the same fashion, but would be in an ON or OFF
state.

The console will have an indicator of the current vehicle speed. The
indicator may be digital or analogue. Analogue indicators require only one
decimal place of precision, but may be reported as integers. Analogue or
digital displays will round the speed up to the next whole number.

B. Ambient light must be monitored to determine when the automobile
headlights automatically go on.

Ambient Light Headlight
(Lumens) Indicator

Less than 1,000 ON (DARK)

1,000 and greater OFF (LIGHT)

The console may either have a graphical indicator, or use an ON /OFF
switch indicator. You may also report light as LIGHT or DARK.

C. Windshield wipers will go on automatically if the precipitation warrants.
They operate at three speeds, so the indicator will read either: OFF, LOW,
MED, or HIGH. Alternatively, the wiper indicator may be set to DRY or

WET.
Precipitation Level | Wiper Speed
0 DRY (OFF)
1 WET (LOW)
2 WET (MED)
3 WET (HIGH)

If your state requires that lights be on when wipers are on, you are free to
include this feature. If itis included, it must be documented.

D. The console will have four tire pressure indicators. If the pressure deviates
from the recommended 32 PSI then an indicator must display a warning.
The message will indicate the tire(s) with a pressure problem, and
calculate and display the difference between the recommended pressure
and the reported pressure. Overinflated tires must be reported the same
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way. Alternatively, tire pressure may be reported as OK, HIGH (HI), or
LOW (LO) instead of computing the difference between desired and

actual.

E. The Engine overheating alert will go on when the engine temperature
exceeds 500 F°. The indicator settings are: NORMAL, WARM, HOT, and
STOP.

Engine Indicator
Temperature (F°)
0 - 500 NORMAL
50171 525 WARM
5261 600 HOT
601 - STOP

F. There must be an indicator that the MC clock is running faster than real-
time. Time will never go below real-time. The indicator will read: 2x, 3,
etc. Pay attention to the calculations and setting that may be affected by
changing the flow of time.

3. Il ndi cators |/ Switches: The terms dindicato
interchangeably. The designer of the Driver Console may adopt either approach,
or a combination, to report the status of any item on the console. All indicators
may be messages, audibleor vi sual (visual is preferred
with beeps, visual; indicators or lights should be circular shapes with a green fill
(okay) or red fill (not okay).

The requirements for each indicator include the settings to be communicated.
4, Testing: An audit trail is necessary to record all status changes. It is not
necessary to perform a screen capture with each change, but it is necessary to

indicate what changed, when it changed, and the new status.

A recommended approach is to have an audit record that indicates the time of
change and the current status of each console item.

Do not generate an audit record every time the clock changes, but do report

changes in clock speed. The audit record will reflect the actual time and the
console clock setting.
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These are possible additions to the system that will be included as time permits.

Instrumentation:

Unit Test Plan:

Regression Test:

Configuration:

4/6/2009 1:16 PM

When a warning indicator is ON, or there is a change in
indicator status, a message appears in a text box with
additional information for the driver.

The Advice Box will also be used during normal operations
to alert the driver to changing conditions.

When the speed indicator is negative, indicating that the car
IS in reverse, a beep will repeat in an annoying fashion until
the speed returns to zero or higher.

The car starts when the DC starts.

5. System Enhancements:
Advice Box:
Backup Beeper:
Ignition Switch:

6. Testing Enhancements:

Include additional parameterized code in the application to
permit testing without the MC. A test bed will be supplied for
the exercise.

Create a unit test plan for the application.
Add additional tests to the test bed and enable the system to
periodically calibrate itself by running specific tests (only one

op code).

Use a configuration file that allows the user to set conditions
such as the speed alert level.
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Appendix

Op Code Table:

OP-CODES Definition Example
DFP Driver side front tire pressure. DFP:32
PFP Passenger side front tire pressure. | PFP:34
DRP Driver side rear tire pressure. DRP:32
PRP Passenger side rear tire pressure. | PRP:30
E Engine Temperature E:500
P Precipitation P:2
T Rate time is flowing. T:1
V Velocity of the vehicle. V:55
L Ambient light. L:1200

A sample test bed will be supplied for the exercise. You are welcome to make
additions to the test bed at the beginning of the development process. The test bed
should remain relatively constant throughout the exercise.
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Console Diagrams

Client (Driver Console / DC)

File Edit
Car Headlights Car Gauges Advice Box
arl . Caution: Wet Roads
Temp Speed Wipers Fuel Light Rear Passenger Tire Pressure Low
D
Tire Pressure
Driver Front: 32 PSI Ok
Pass Front: 32Psl oK [ |
Driver Rear: 32 PSI Ok
Pass Rear: 10 PEI Loy D L q] M I D
Time D Gas Mileage
35 MPH
Elapsed: 335558 400 F 1 a0 GAL a0L PG
MORM Ok Loy Ok NARK
Rate: 1x Remaining Fuel

Server (Master Control Console / MCC)

File View Edit

Misc. Controls Tire Pressure

Temp Speed Precip Time Rate Light Driver Front Driver Rear Pass Front Pass Rear

(+) (+) (+) (+) +) +) (+) (+) (+)

Engine Temperature | Hl | | | |
[ [ [ [
c || % |0 B — — : : —
) -) -) -) -) ) -) -) -)
aF OmPH Mone 1 1400L 32PSI 32PS1 32PEI 32PEI
Clients Connected: 2
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Development Notes:

These are some of the elements of the system to consider while adding code to the DC.

1.

Most of the required code is already in the DC. Your responsibility is to code the
validations and the calculations that indicate when warning messages must be
issued.

You must be able to execute your program with a parameter that tells it to either
work with the MCC, or to accept values from the test bed. It will enable you to
produce an audit trail with known results. Examining the audit trail after making
coding changes in the application will alert you to any introduced defects. Using
a standard test bed is essential to performing a regression test.

When the vehicle is exceeding the recommended speed of 55 MPH, the warning
or alert message is displayed. Consider what will happen if the vehicle travels at
the excessive speed for an extended period of time. (A little fuzzy logic may be
required.)

Be certain to liberally comment your code. Pre-conditions and post-conditions
are essential pieces of information.

Give some thought to how you will go about comparing the regression test
results from run to run.
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e-CRUISE CONTROL

Testing Process

The following table starts to examine some of the testing that will be implemented in
the e-Cruise control application.

3

Test

Description

Unit testing

Performed manually by the developer following a written unit
test plan. Tests will utilize a local copy of the Master
Console.

System Testing

Performed by the developer following a written system test
plan. Tests will use a local copy of the Master Console.
When all tests pass with the local copy of the Master Console
the remote program will also be used for testing.

Automated Testing

Unit and system tests may be performed using a test bed. A
sample test bed is available on Blackboard with the latest
copy of the specification.

The MCC is run locally and sends messages (op codes with values) directly to the DC.
The DC responds to each message and creates an audit trail that reflects all of the
changes. The audit trail is then compared to the previous audit trail to be certain that

they are identical.

Master Control Console

Driver Console

4/6/2009 1:16 PM
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The Master Control Console may also be run on a remote computer. The tests will be
identical to the tests performed locally, but the tests will also confirm that the
communication features are operational.

Master Control Console

Temo | Speed
1 Tire Py
o
o e

Driver Console

B e e — e e S

Audit Trail

Automating the testing process incorporates a test bed that replaces the MCC. All of
the messages are input from the test bed. Once again the comparison of audit trails
will determine if the system is processing the messages properly.

Driver Console

»»»»»

CorHeaahis

Test Bed
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FINAL LAB - E-CRUISE CONTROL
Due Date: 12/08/08 (Beginning of Lab) No Late Assignments Will Be Accepted

Each student is tionplement the logicof the Driver Console. The logic should have already been
established from the previous assignment. (The Test PlaioriPof this lab).

Here is where we are going with this:

On Monday, December 8th,emvill meet in room 215 Wachman Hall.

Prof. Sorkin and will be present.

Our MCC Server will be running.

You will connect your DC to our MCC.

We will send your DC opodes.

Your DC should react to the @pdes as defined by the Specification.

When the experiment is over you will post your DC's audit trail to your website. The audit trail
is saved in a file callebg.html

¢ You will email the link to the audit trail to me. 803747 @temple.edu)

To start this assignment you will first need to download\tetbeans projects. You can find the files
here:

e Driver Console
e Master Control Console
e Test Module (Faux MCC)

| have tested these projects in Netbeans 6.0 and Netbeans 6.1.
The documentation for each project can henfbhere:

e DC JavaDocs
¢ MCC JavaDocs
e TestModule JavaDocs

You should really only be concerned with the DC JavaDocs, as this is where you will find the api for
what you need to edit.

Your main area of interest is the IntelligenceModule Class. You will need to place the logic for the DC
in theinterpretData() method. | will explain more during lab. You will also need to study how to use
thesetGauge(Jandsetindicator() methods of the ClientControlPanel class.

The Test Module application is used as a false MCC. It reads a seriesanfaspfronthe provided test
bed and sends them to the connected DC.

I will show you during lab how to run all of the applications.
I should receive the following items from each of youDmtember 8th

1. By Beginning of Class:DC Source Code, Test Plan
2. By End of Class: A Link To Your Audit Trail
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http://lucas.cis.temple.edu/~jthompson/Download/DC.zip
http://lucas.cis.temple.edu/~jthompson/Download/MCC.zip
http://lucas.cis.temple.edu/~jthompson/Download/TestModule.zip
http://lucas.cis.temple.edu/~jthompson/DCDOCS/index.html
http://lucas.cis.temple.edu/~jthompson/MCCDOCS/index.html
http://lucas.cis.temple.edu/~jthompson/TESTDOCS/index.html

e-Cruise Control Programmer's Guide
e-Cruise Control Consists of two java applications:

1. MCC - The Master Control Console
2. DC - The Driver Console

The MCC is the acting server of the software suite. It is for all intents and purposes
finalized and requires no further development by the student developers. However,
each student will be presented with a copy enabling them access to the MCC at all
times, during the finalization of the development of the DC.

THE MCC
To start the MCC:

« If you are launching the MCC through netbeans simply press F6 to compile
and run the project. If you need to know how to open a Project in Netbeans
click here.

« If you are launching the MCC through the windows installer (Not Yet
Available), simply install the application and click on the desktop icon to run
the application.

The MCC automatically determines your computer's IP Address. The first time you
run the application you should receive a message displaying your current IP
Address and the Port with which the MCC will accept connections through. This
information needs to be emailed to any person using a DC that wishes to connect
to your MCC.

Should a message not appear stating that the IP Address has changed than the
most likely cause is that you are not connected to the internet and the MCC is
using the "local host" configuration. You can check to see what your IP Address is
at anytime through the Edit -> Settings menu.
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Once the MCC is online and is assigned an IP Address no further configuring is
needed. Simply begin to use the application. Any DCs that connect will
automatically receive the current environment conditions:

« Rain conditions

o Tire pressure for all 4 wheels
o Ambient light

o Rate time is flowing

o Speed of the vehicle

The MCC will only send information when the state of one of its sliders changes.
Each connected DC will receive the updated information.

To view connected DCs click the View -> View Clients Menu. The MCC will try to
communicate information to the DCs. If for some reason the connection is lost, the
MCC will delete the DC from the list of connected DCs.

THE DC
To start the DC:

o If you are launching the DC through Netbeans simply press F6 to compile
and run the project. If you need to know how to open an Project in Netbeans
click here.

« If you are launching the DC through the windows installer (Not Yet
Available), simply install the application and click on the desktop icon to run
the application.

The DC will open in an un-connected state. To open a connection the user must
enter the MCC connection information provided by an email or word of mouth of the
MCC user. To enter the IP Address and Connection Port information click on the
Edit -> Settings menu. Enter the information in the dialog box and save the
changes.
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To initiate communication with the MCC click File -> Connect... menu. The DC will
attempt communication with the MCC. Should the DC fail to connect to the MCC
after 4 seconds the connection attempt will cease and an error message will be
displayed. Ensure that the connection information is correct in the Edit -> Settings
menu. Should an error occur again than the connection is most likely being blocked
by a network Firewall. See your network administrator to resolve the problem.

Communication OP-CODES

The MCC relates current running environment conditions for the DC. It provides
information to the DCs using a TCP/IP implementation. To limit the amount of
information transmitted over the network the MCC transmits OP-CODES that
identify what environment condition changed and the current value of that
environment condition. These OP-CODES need to be translated by the DCs.

The OP-CODES are as follows:

DFP# - Driver side front tire pressure.
PFP# - Passenger side front tire pressure.
DRP# - Driver side rear tire pressure.
PRP# - Passenger side rear tire pressure.
E# - Engine Temperature

P+ - I

S o
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